Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Amateurfilm-Forum. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich
  • »Borgory« ist der Autor dieses Themas

Beiträge: 2 972

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 48

  • Private Nachricht senden

1

Mittwoch, 3. Juni 2009, 20:04

Schattenproblem in C4D

Ich versuche den ganzen Tag krampfhaft den Schatten von meiner Animation rauszurender. Ich habe es zwar endlich geschafft nur der Schatten sieht doof aus. Ich habe es mit dem Lightdome ausgeleuchtet, weil es mir gefällt mit dem dichteren Schatten unter den Füßen. Dafür sieht aber der Rest scheiße aus^^ Es sind immer mehrere Schatten zu sehen. Kann man das nicht irgendwie so einstellen dass zwar die 2 dicken schwarzen Punkte bleiben und der rest weg ist? Durch eine andere Lichtquelle kann ich ja dann die richtung des Körperschattens bestimmen.

Bild:

Jumperman

unregistriert

2

Mittwoch, 3. Juni 2009, 21:15

Lass Lightdome weg und rendere es lieber mit AmbientOcclusion. Dann hast du auch unter den Füßen einen dichten dunklen Schatten und drumrum nur den normalen von einer Lichtquelle (oder eben mehreren Lichtquellen, kommt auf deine Ausleuchtung an).

Erkenne ich da einen T-Rex? :D

3

Mittwoch, 3. Juni 2009, 21:58

Joa.... ich würde auch einfach mit Ambient Occlusion oder GI rendern. Mit Gi dauert das rendern dann zwar länger, aber ich denke das wäre die einfachste Lösung.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »HTP« (3. Juni 2009, 22:04)


Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich
  • »Borgory« ist der Autor dieses Themas

Beiträge: 2 972

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 48

  • Private Nachricht senden

4

Mittwoch, 3. Juni 2009, 22:07

Probiere ich gleich mal aus :D
Jo Jumperman, du erkennst es richtig :thumbsup: Vielleicht läuft er ja morgen den einen oder anderen hier im Forum übern Weg ;)

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich
  • »Borgory« ist der Autor dieses Themas

Beiträge: 2 972

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 48

  • Private Nachricht senden

5

Donnerstag, 4. Juni 2009, 10:48

Ich bekomme es nicht hin -.- Muß ich da irgendetwas beachten bei Ambient Occlusion? Ich habe eine Lichtquelle drin, da ich ja nur den Schatten brauche und nicht das Modell. Aber irgendwie seh ich keinen unterschied^^

Jumperman

unregistriert

6

Donnerstag, 4. Juni 2009, 12:05

Wenn du das Modell über einen Rendertag ausgeblendet hast, dann achte darauf, dass der Haken bei "Sichtbar für AO" aktiviert ist.

Dann musst du in den Renderoptionen natürlich AmbientOcclusion als Effekt hinzufügen. Theoretisch ist es fertig zum Rendern. Du kannst es jetzt aber noch in den Rendersettings optimieren.
Natürlich sollte "Auf Szene wirken" aktiviert sein. Es sein denn, du möchtest es als seperaten Multi-Pass-Kanal rendern.
"Maximum Strahlenlänge" hängt von der Größe deines Models ab. Da musst du rumprobieren, bis es passt.
"Genauigkeit" kannst du locker auf einen Wert 60-70% stellen.
Und bei den Samples mach ich immer Werte von Min. 4 bis Max. 64
"Nur Eigenbeschattung" sollte in deinem Fall deaktiviert sein.

So hat es ein gutes Qualitäts-Renderzeit-Verhältnis. Also zumindest in meinen Augen. Musst natürlich immer ein bißchen austesten, wie es am besten aussieht.

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich
  • »Borgory« ist der Autor dieses Themas

Beiträge: 2 972

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 48

  • Private Nachricht senden

7

Donnerstag, 4. Juni 2009, 12:09

Danke! Habe es hinbekommen und die Renderzeit war auch schnell (wenn 12sek. schnell sind^^)! Ietzt kann ich denk ich den Rest fertig machen :thumbsup: Noch mal vielen Dank!!!

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich
  • »Borgory« ist der Autor dieses Themas

Beiträge: 2 972

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 48

  • Private Nachricht senden

8

Donnerstag, 4. Juni 2009, 12:31

So wie ich meinen Schatten nun habe will er sich aber nicht als alpha rendern lassen. Der Shadowcatcher macht da irgendwas falsch^^

Ohne Shadowcatcher, aber dafür mit nicht erwünschten Boden:


Mit Shadowcatcher aber ohne erwünschten schatten:


Gibt es nicht eine möglichkeint den Schatten so rauszurendern wie auf Bild 1?

Jumperman

unregistriert

9

Donnerstag, 4. Juni 2009, 14:17

Ich verstehe das Problem nicht ganz.
Möchtest du den Schatten quasi mit Alphakanal gerendert haben?
Du kannst den Schatten ja - wenn er weißen Hintergrund hat - auch mit "Multiplizieren" oder als AlphaMaske über dein Video legen.

oder verstehe ich was falsch?

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich
  • »Borgory« ist der Autor dieses Themas

Beiträge: 2 972

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 48

  • Private Nachricht senden

10

Donnerstag, 4. Juni 2009, 14:29

Funktioniert das so einfach mit dem weissen Hintergrund? Ich glaub ich hatte das versucht, das Problem war dabei glaube ich dass ich den Schatten glaube ich nicht weiter hell oder dunkler stellen konnte, weil dann der Rest auch sich farblich ändert. Also das ganze bild wird dann mit dunkler.

Ich teste es noch mal, bis jetzt habe ich es halt so wie auf dem 2. Bild gemacht.

Ok, dass haut so hin :) Statt die Helligkeit brauch ich ja nur die Deckkraft runter drehen :rolleyes: Es rendert sogar noch schneller^^

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Borgory« (4. Juni 2009, 14:38)


Ähnliche Themen

Social Bookmarks