Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Amateurfilm-Forum. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

Marcus Gräfe

Administrator

  • »Marcus Gräfe« ist männlich
  • »Marcus Gräfe« ist der Autor dieses Themas

Beiträge: 5 021

Dabei seit: 14. August 2002

Wohnort: Düsseldorf

Hilfreich-Bewertungen: 312

  • Private Nachricht senden

1

Donnerstag, 9. Februar 2017, 21:17

AE CS6: Unterkomposition mit 25 fps in Komposition mit 50 fps setzen - Problem mit doppelten Frames

Ich habe schon immer folgendes Problem in After Effects CS6 und heute starte ich mal einen Thread dazu. Folgender Fall:

- Clip mit 1080p25 liegt vor
- Komposition wird erstellt mit 720p50 (das ist auch das Format des Films, in welchen diese Komp. eingesetzt wird, weil die meisten Clips 720p50 sind)
- 1080p25-Clip kommt in diese Komp. und wird kleiner skaliert (das ist aber für das Problem irrelevant), es soll etwas retuschiert werden

Wenn sich die Kamera bewegt und ich die Retusche mitbewegen möchte, so gibt es nun das Problem, dass jeder Frame doppelt so lange steht (also zwei Frames lang) und ich jeden Keyframe 2x setzen muss.

Es ist natürlich logisch, dass die Frames verdoppelt werden, weil ich 25p in 50p einsetze. Aber es ist sehr mühselig, etwas Frame-für-Frame zu animieren, egal ob Maskenpfade oder Positionsänderungen, wenn man jeden Punkt 2x setzen muss.

Nun dachte ich, kein Problem, mache ich eben eine Unterkomposition mit 1080p25 und darin die Retusche. Diese sieht darin auch top aus und macht keine Probleme beim Erstellen. In der 720p50-Komp. liegt nun also die korrekt animierte Retusche.

Aber leider ist es dann so, dass sich die Retusche in den verdoppelten Frames zu früh bewegt. Also in Frame 1 sehe ich die Retusche von Frame 1, in #2 die Retusche von Frame #3, in #3 von #3, in #4 von #5, in #5 von #5 usw.

Also warum wird der Frame der Retuscheebene nicht auch doppelt gezeigt, so wie vom Originalvideo? Warum bewegt sich diese trotz Unterkomposition anders? Selbstverständlich habe ich "Transformationen falten" mal aus- und wieder eingeschaltet, das bringt keinen Unterschied.

Die Frage kann man auch alternativ stellen: Wie erreiche ich, dass die Ausgabe einer Unterkomposition wie von einem Rendering ist? Also dass AE erst diese UKomp. rendert und dieses Bild dann in der Hauptkomp. anzeigt. Im Moment muss ich mir damit behelfen, dass ich ein Zwischenrendering mache. Das macht Dynamic Link natürlich nutzlos.

LennO

Registrierter Benutzer

Beiträge: 353

Dabei seit: 3. Juni 2015

Hilfreich-Bewertungen: 117

  • Private Nachricht senden

2

Freitag, 10. Februar 2017, 14:55

In den erweiterten Einstellungen einer Komposition (deiner Unterkomp) gibt es nach meiner Erinnerung eine Option die so ähnlich heisst wie "Zeit/Framerate bei Verschachtelung beibehalten". Das ist das was du suchst, denke ich.

Es haben bereits 2 registrierte Benutzer diesen Beitrag als hilfreich eingestuft.

Benutzer, die diesen Beitrag hilfreich fanden:

Marcus Gräfe, Selon Fischer

Marcus Gräfe

Administrator

  • »Marcus Gräfe« ist männlich
  • »Marcus Gräfe« ist der Autor dieses Themas

Beiträge: 5 021

Dabei seit: 14. August 2002

Wohnort: Düsseldorf

Hilfreich-Bewertungen: 312

  • Private Nachricht senden

3

Samstag, 11. Februar 2017, 17:05

Ach, wie einfach... ;)

Danke!

Für alle zukünftigen Suchenden: Die Einstellung heißt "Bei Verschachtelung oder in Renderliste bleibt die Framerate erhalten", hier ein Screenshot aus AE CS6:


Social Bookmarks