Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Amateurfilm-Forum. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

1

Dienstag, 20. August 2013, 21:46

Cinema 4d tracking

Hallo zusammen :)

Bin gerade dabei zu lernen wie 3d tracking mit Boujou und Cinema4d funktioniert. Ich mache alles genau wie die in den Tutorials, wenn ich aber mein Video rendere bewegt sich das Objekt trotzdem nicht sehr stark aber man merk es halt... Hat ja wer eine Ahnung was ich falsch mache oder hatte mal das selbe Problem gehabt? Danke für jede Antwort. Mfg Felix

steven_skywalker

Registrierter Benutzer

  • »steven_skywalker« ist männlich

Beiträge: 95

Dabei seit: 13. Mai 2013

Hilfreich-Bewertungen: 7

  • Private Nachricht senden

2

Dienstag, 20. August 2013, 23:53

Was hast du für Ausgangsmaterial, sprich was für Videomaterial wird getrackt?

Ist nämlich recht entscheidend für ein sauberes Tracking und das anschliessende Ergebnis.

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

3

Freitag, 23. August 2013, 11:18

Also falls du die Qualität meinst, ich filme 24 Frames in Full HD mit meiner Canon 60 D

steven_skywalker

Registrierter Benutzer

  • »steven_skywalker« ist männlich

Beiträge: 95

Dabei seit: 13. Mai 2013

Hilfreich-Bewertungen: 7

  • Private Nachricht senden

4

Freitag, 23. August 2013, 11:50

Hmm das sollte dann ja nich all zu schlecht sein ...

Stimmt die Positionierung des 3D-Objekts vlt. nicht ganz?

Ich bin sowieso eigentlich eher ein 3D-Laie als Profi, aber vlt. ists ja nur was ganz einfaches ... sonst würde ich passen )=

Viel Glück!

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

5

Freitag, 23. August 2013, 12:09

Die Position sollte eigentlich stimmen .. hmm

steven_skywalker

Registrierter Benutzer

  • »steven_skywalker« ist männlich

Beiträge: 95

Dabei seit: 13. Mai 2013

Hilfreich-Bewertungen: 7

  • Private Nachricht senden

6

Freitag, 23. August 2013, 12:43

Nun ja, möglicherweise hat sonst wer eine Erklärung. Lies oder "schau" dich doch nochmal ins Thema Tracking ein, vorallem was die Software betrifft, mit Hilfe von Tutorials, Youtube etc.

Möglicherweise findest du da den entsprechenden, fehlenden Hinweis.

Falls du das schon gemacht hast oder eh noch tust, um so besser :D

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

7

Freitag, 23. August 2013, 13:00

Okey danke trotzdem für deine Antworten, habe es schon 10mal nach verschiedenen Tuts versucht haha :/ klappt leider immer noch nicht. Es bewegt sich immer noch ein wenig.

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

8

Freitag, 23. August 2013, 14:25

https://vimeo.com/72967358 Hier ein video damit ihr sehen könnt was ich meine..

z3r0_88

Registrierter Benutzer

  • »z3r0_88« ist männlich

Beiträge: 76

Dabei seit: 5. April 2013

Wohnort: Lüneburg

Hilfreich-Bewertungen: 2

  • Private Nachricht senden

9

Freitag, 23. August 2013, 14:39

Um es in 7 Sekunden beurteilen zu können muss man wohl Profi sein.
Ich würde jedoch sagen, dass keine ordentlichen Trackingpunkte da sind.
Profis arbeiten mit Kontrastreichen Trackingpunkten, die am Ende von dem Objekt verdeckt sind.

Hier ein Bild welches ich bei Google dazu gefinden haben


Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

10

Freitag, 23. August 2013, 15:29

Danke für die Antwort .. Hab jetzt nochmal getrackt mit extra Punkten. Funktioniert immer noch nicht :(

z3r0_88

Registrierter Benutzer

  • »z3r0_88« ist männlich

Beiträge: 76

Dabei seit: 5. April 2013

Wohnort: Lüneburg

Hilfreich-Bewertungen: 2

  • Private Nachricht senden

11

Freitag, 23. August 2013, 15:31

Werde mich am wochenende mal hinsetzen und einen trackingversuch in C4D machen, vielleicht kann ich dir dann mehr sagen.

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

12

Freitag, 23. August 2013, 16:27

Okey , danke :) Falls sonst noch wer eine Idee hätte , immer her damit :)

cj-networx

Möchtegernfilmer

  • »cj-networx« ist männlich

Beiträge: 687

Dabei seit: 18. November 2005

Wohnort: Höxter

Hilfreich-Bewertungen: 20

  • Private Nachricht senden

13

Freitag, 23. August 2013, 23:37

@Pixelrangers
In deinem Video sehe ich keine Fehler, alles bewegt sich aus meiner Sicht wie es sein soll. Der graue Quader bewegt sich finde ich auch normal.
Was hast du den selber am Video zu bemängeln?
-------------------------------------
Amateurfilmer+Hobbyfotograf
www.cj-networx.de

fotografische Postkarten
live :: eCards

Dr_Allcome

Registrierter Benutzer

Beiträge: 239

Dabei seit: 12. April 2012

Hilfreich-Bewertungen: 66

  • Private Nachricht senden

14

Samstag, 24. August 2013, 09:44

@Pixelrangers
In deinem Video sehe ich keine Fehler, alles bewegt sich aus meiner Sicht wie es sein soll. Der graue Quader bewegt sich finde ich auch normal.
Was hast du den selber am Video zu bemängeln?


Das sieht man auf Vimeo nicht richtig, weil man nicht vernünftig hin- und herspulen kann. Lade das Video einfach mal runter, dann siehst du, dass sich der Würfel im Verhältnis zum Stift bewegt. Bei Objekten, die sich passgenauer in die Szene einfügen sollen, würde das mehr auffallen.

@Pixelrangers
Ich denke, dass hier die Abbildungsfehler der Linse einfach nicht korrekt herausgerechnet wurden. Man sieht, dass der größte Fehler entsteht wenn der Cube von links ins Bild wandert, also an den Rändern wo Kameralinsen den größten Fehler aufweisen. Von der Mitte ab passt es dann eigentlich wieder recht gut. Für ein besseres Ergebnis müsstest du also die Abbildungsfehler deiner Linse angeben. Die musst du halt für deine Linse errechnen lassen indem du mal ein Grid filmst und dann das Bild so verzerrst bis alles wieder gerade Linien sind. Daraus kann man dann die Abbildungsfehler deiner Linse berechnen und beim Tracking berücksichtigen.

Zusätzlich musst du beim Tracking natürlich auch darauf achten, dass du die Brennweite möglichst korrekt angibst, da besonders die Verzerrungen von Weitwinkelobjektiven ja berücksichtigt werden müssen.

JorJas

Liebt Photoshop über alles!

  • »JorJas« ist männlich

Beiträge: 44

Dabei seit: 28. Juli 2012

Wohnort: Hanau

Hilfreich-Bewertungen: 3

  • Private Nachricht senden

15

Samstag, 24. August 2013, 11:20

Ich habe auch das Problem mal gehabt und bei mir hat sich das gelöst, als ich die Trackingdatei von Cinema 4D bearbeitet habe. Das Tutorial dazu findet sich hier:
http://www.youtube.com/watch?v=mh1QP4FTDY ( Das Umschreiben fängt bei 9:12 Minuten an)

Vielleicht hilft es dir ja :D

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

16

Samstag, 24. August 2013, 20:03

Hey danke für die Antworten werde es nochmal versuchen :)@JorJas : Das video gibt es nicht mehr oO ^^

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

17

Samstag, 31. August 2013, 21:11

So , nach langem versuchen ect. Funktioniert es leider immer noch nicht. Andere haben schlechtere VideoQualität und doch geht es ... Hat noch jemand eine Idee ? Liebe Grüße Felix.

Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

18

Freitag, 6. September 2013, 17:43

*PUSH* Jemand noch einen Tipp ?

Mac Mave

Filmzombie

  • »Mac Mave« ist männlich

Beiträge: 1 398

Dabei seit: 20. Juli 2005

Hilfreich-Bewertungen: 130

  • Private Nachricht senden

19

Samstag, 7. September 2013, 06:29

Da ich leider auch öfters tracken muss, kenne ich das Problem:

Mögliche Fehlerquellen:
- Objektiv-Einstellung in Milimeter stimmt nicht mit der verwendeten Linse überein.
- Versch. Frameraten in der Trackingsoftware und im 3D Programm
- Proportionen stimmen nicht, die Maßeinheiten müssen im 3D Programm stimmen. Schau dazu in der Doku deiner Tracking-Software - da steht drin wie die die Grund-Maßeinheiten in deinem 3D Programm einstellen muss. Manche wollen zB kein Metrisches System etc. Die Maße sollten also stimmen - auf einem gefilmten Schreibtisch von einem Meter Tiefe kann kein 4x4 Meter Quader im 3D Programm liegen.
- Tracking Methode: Free Tracking oder nicht?
- Groundplane / Trackmarker im 3D Programm falsch gesetzt - ein Millimeter zu weit vorn oder hinten und schon schwimmt dein 3D Modell.
- Schlechtes Ausgangsmaterial - vom Jello Effekt der DSLRs bis hin zu übermäßigem Parallax bewegen der Kamera. Manchmal kann man es halt einfach nicht (besser) tracken.
- Du kannst in vielen Tracking-Programmen (kenne Boujou nur vom Hörensagen) die Proportionen festlegen, die einzelnen Abstände der Tracking Punkte voneinander in cm.
- Auch kann man an sichtbaren geraden Linien im Video oft im Tracking Programm eine Gerade von A nach B nachziehen und sich die Länge festlegen. Gut für die Proportionen und dein Tracking Programm sollte daran auch gleich erkennen wie deine Linsenverzerrung des Objektivs ist.
- Das Track-Ergebniss entkernen, sprich die schlechten Punkte gar nicht erst in das Kamera-Solving einfließen lassen.

Zu deinem Video: Tracking Punkte gibt's da genug. Ich denke es ist die Kamerabewegung - damit meine ich zum einen den Schwenk, der zu Parallax verläuft und die Kamera wippt von vorn nach hinten und schwankt in sich selbst von links nach rechts. Ich meine auch hier bisserl DSLR Jellow gesehen zu haben, da solltest du langsamere Schwenks machen (wenn überhaupt Schwenks?), Shutter hoch und entweder eine richtig ruhige Hand oder gleich vom Stativ. Wackeln kannst du nachträglich hinzufügen.

Vielleicht lädts du deine Footage wo hoch, dann kann der ein oder andere mal sein Glück versuchen ;-)

Ich bin mittlerweile großer Fan des 3D Trackers in After Effects - lässt sich wunderbar nach C4D exportieren und die Ergebnisse sind sehr geil! Nur falls das hilft ;-)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mac Mave« (7. September 2013, 06:38)


Pixelrangers

Registrierter Benutzer

  • »Pixelrangers« ist der Autor dieses Themas

Beiträge: 18

Dabei seit: 30. Juli 2013

  • Private Nachricht senden

20

Samstag, 7. September 2013, 17:49

@Mac Mave Hey, vielen dank für die Tipps :) kennst du ein gutes Tutorial wo gezeigt wird wie ich von after effects nach Cinema 4d exportieren kann also die Tracking Points ? Liebe Grüße Felix

Social Bookmarks