Du bist nicht angemeldet.

Iquitos

unregistriert

1

Samstag, 17. Januar 2009, 20:26

3ds Dateien in Cinema4D importieren?

Guten n´Abend,

Ich habe Cinema4D und bin nun auf ein paar 3ds Vorlagen gestoßen, die ich nun in Cinema4D importiert habe, weil ich kein 3ds Max habe.

Sind die Ergebnisse in Cinema4D jetzt genauso wie in 3ds Max ?

Ich hoffe jemand hat dort schon Erfahrung gemacht! ;)

mfg. Iquitos

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich

Beiträge: 2 924

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 46

  • Private Nachricht senden

2

Samstag, 17. Januar 2009, 20:33

Ich finde das teilweise Max bessere Renders macht. Ich habe noch keinen richtigen vergleich machen können, da das Modell im C4D nicht Texturiert ist wie im Max. Ich habe zur Zeit die Trial drauf von Max und stelle fest das ich damit fast überhaupt nicht klar komme. C4D finde ich persönlich viel leichter und die Ergebnisse reichen mir auch.

Aldaros

Timelord

  • »Aldaros« ist männlich

Beiträge: 681

Dabei seit: 24. August 2005

  • Private Nachricht senden

3

Samstag, 17. Januar 2009, 22:27

@Iquitos

Natürlich kannst du 3ds Dateien importieren....wie aber Borgory bereits erwähnte werden dabei die Materialeinstellungen verrissen. 3Ds Max erstellt wie C4D auch Polygonale Objekte...das Texturieren funktioniert dort allerdings etwas anders bzw. C4D kann mit diesen Einstellungen nichts anfangen.

AAber: Meistens sind bei den Objekten ja texturen...also Bilder dabei, wie Bumpmaps,Displacementmaps etc. Diese kannst du in C4D (zumindest meiner Erfahrung nach) ganz normal im Materialeditor laden. Also einfach ein neues Material erstellen,die Textur in den entsprechenden Kanal laden et voila. Natürlich sieht es dann nie so aus wie auf den tollen Vorschaubildern des Erzeugers...die ja mit 3Ds max gemacht worden sind. Hier kommt etwas kreativität ins Spiel....ergo musst du die Kanäle die du NICHT über eine geladene Textur ansteuern kannst per Hand so einstellen wie es sein sollte.

Ich hab das z.b. beim 3dsmax Modell der Daedalus aus Stargate gemacht...von scifimeshes war die glaube ich....da waren es dann die Farb bzw Glanzlichteinstellungen die ich neu basteln musste.

Aber alles in allem: Ist machbar.Ohne Handarbeit geht es jedoch nicht

@Borgory Dass 3Dsmax bessere Renderings macht halte ich für ein Gerücht. Es kommt immernoch darauf an wer es bedient.Natürlich gibt es für 3Dsmax ganz tolle Plugins...da es halt ein Programm ist dass einige Nutzer mehr aufweisen kann als C4D. Aber C4D ist auch schwer im kommen. Soweit ich weiss gibt es z.b. von einigen kommerziell erwerbbaren Renderengines sowohl für c4d als auch für 3dsmax entsprechende Versionen.



Edit: Grad gelesen: Z.b. die Renderman engine von Pixar lässt sich mittlerweile in C4d integrieren. Ergo möchte ich den sehen der mit 3dsmax etwas rendert was C4d nicht kann. Allerdings soll 3Dsmax die überlegenen Partikeleffekte haben...das mag wohl sein
"Filme drehen ist entweder eine wunderbare Utopie oder Scheisse den Berg hochschaufeln"

Sir Sean Connery

"...und es steht geschrieben: Wenn du einschenkst,wird er kommen"

Denny Crane
[myshare]p14696681446[/myshare]

MichaMedia

unregistriert

4

Sonntag, 18. Januar 2009, 00:21

Nein alles Falsch, 3d max, bzw. 3DS benutzt nur eine andere Datenstruktur zu Pfaden seiner Texturen, wenn man den Ort der Texturen als Texturpfad zuvor in C4D angibt, gibt es kaum Probleme.
Selten stimmen einige UV Angaben nicht oder relative Größen, dies kann man am Import-faktor aber fest machen in den Einstellungen bei C4D.
Bump und Displacement muß man angleichen, relativistisch zum Import Faktor, das ist auch alles bei 99% aller Importe, nicht nur bei 3DS sondern bei allen Fremdformaten mit Scalefaktor.

Ich habe noch nie Probleme dazu gehabt, C4D bietet genug Zeilen für relative texturpfade ;)

Gruß Micha.

Aldaros

Timelord

  • »Aldaros« ist männlich

Beiträge: 681

Dabei seit: 24. August 2005

  • Private Nachricht senden

5

Sonntag, 18. Januar 2009, 01:25

Ähm...Micha,das stimmt so nicht. Ich hab es eben grad mit einem 3Ds Modell ausprobiert und die Dateipfade wurden,da sie im Stammverzeichnis der Projektdatei lagen automatisch gefunden. Die Struktur der übereinandergelegten Kanäle war aber trotzdem bockmist. In meinem Falle wars ein Borgwürfel :) der,im Gegensatz zum sollzustand einfach nur grün war. Alle Texturpfade waren korrekt.

Könnte natürlich sein dass es auf die jeweilige datei ankommt UND ob es .3ds oder .max ist....c4d hat imho mehr probleme mit .max. Aber wie gesagt....trotz korrekter Texturpfade waren alle anderen Einstellungen schlichter blödsinn bzw. hatten mit dem Zustand wie es hätte aussehen sollen nichts gemein. Hast du mal nen Link zu einer Beispieldatei wo das bei dir so war?
"Filme drehen ist entweder eine wunderbare Utopie oder Scheisse den Berg hochschaufeln"

Sir Sean Connery

"...und es steht geschrieben: Wenn du einschenkst,wird er kommen"

Denny Crane
[myshare]p14696681446[/myshare]

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich

Beiträge: 2 924

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 46

  • Private Nachricht senden

6

Sonntag, 18. Januar 2009, 12:20

Also ich kann .max Dateien gleich gar nicht im C4D öffnen. Mit den Texturen ist es bei mir so das sie zwar geladen sind aber mein Modell trotzdem nackig ist. Ich müsste alle Texturen neu zuweisen was aber auch nicht richtig hin haut. UVW Mappig hat gleicht gar nicht eklappt, ich habe nur die Grundfarbe da aber wenn auf der Textur noch andere unebenheiten sind weden die komischer Weise nicht angezeigt. Mit einen anderen Mapping geht es wiederum nicht...oder ich bin zu doof. :thumbsup: Ich habe das Problem mit der .3ds Datei von Grievous (scifi3d.com) Die Datei ist sicherlich nur exportiert aus 3dsMax und geht deswegen nicht.

MichaMedia

unregistriert

7

Sonntag, 18. Januar 2009, 16:32

Hm, ich habe leider nicht mehr die orginal 3ds Dateien, alle schon in C4D verbaut, ich pack die auch nie im Projektordner, daher die Pfade anpassen. Es waren überwiegend Kampstern Galactica Sachen (Zylonen und so) und auch einige Sachen aus SW Bereich, so wie viele Kleinteile (Gegenstände von Kerze bis Aschenbecher).
Ich kann mich nur bei einem Auto, glaub nen Ferrarie, erinnern das da Fehler waren.

Vielleicht hatte ich so gut wie immer Glück und passende Modelle gefunden.
@Aldaros, hast mal nen Link zum Borgwürfel, dann teste ich den mal an, vielleicht kann ich dann mehr zu sagen.

Gruß Micha.

Aldaros

Timelord

  • »Aldaros« ist männlich

Beiträge: 681

Dabei seit: 24. August 2005

  • Private Nachricht senden

8

Sonntag, 18. Januar 2009, 17:11

http://www.startrekmeshes.com/startrek/b…gcube/index.htm

Einmal Link wie bestellt...bittesehr. Also alles ohne Gewähr da ich natürlich auch nciht die Weisheit mit Löffeln gefressen habe....aber wie du siehst,siehst du,dass du garnix siehst.....das Modell so geladen bei mir in C4D R10 ergibt einen grünen Würfel. Wo mich schonma interessieren würde wo das grün herkommt. Wenn du die DAteien in der .zip einfach in EINEN Ordner entpackst müssten auch die Texturpfade stimmen.

Edit: Weil du sagst du hast mehrere Sachen ausprobiert....das deckt sich soweit mit meinen Beobachtungen...ich denke man kann sagen dass die "VErträglichkeit" von 3Dsmax modellen variiert. Ich hatte auch schon modelle da wars garkein Problem....so z.b. bei der Daedalus. Einfach die Texturpfade geladen und Glanzlicht korrigiert. Da dürfte dieser Borgcube (falls ich nichts grob fahrlässig übersehen habe) schon ein worstcase fall sein. Aber genau darum gehts ja :)
"Filme drehen ist entweder eine wunderbare Utopie oder Scheisse den Berg hochschaufeln"

Sir Sean Connery

"...und es steht geschrieben: Wenn du einschenkst,wird er kommen"

Denny Crane
[myshare]p14696681446[/myshare]

Borgory

Registrierter Beschmutzer

  • »Borgory« ist männlich

Beiträge: 2 924

Dabei seit: 21. Oktober 2008

Hilfreich-Bewertungen: 46

  • Private Nachricht senden

9

Sonntag, 18. Januar 2009, 18:35

Ich glaube auch wenn man das in einen Ordner entpackt besteht noch der alte Pfad wo du deine letzten Texturen her geholt hast. Ich packe immer alle Texturen in meinen Textur-Ordner und dann stimmt es, dann kommt keine Fehlermeldung mehr beim rendern dass die Texturen fehlen. Das einzige was immer mal noch passiert ist, dass die Materialien trotzdem grau sind und gar keine Texturen beinhalten aber richtig am Modell angeordnet sind (die MAT).

MichaMedia

unregistriert

10

Sonntag, 18. Januar 2009, 18:55

Also das grüne beim Borgcube kommt von den ganzen Lichtern, die sind grün ;)

Aber Du hast recht, da ist ein Fehler drinn, die Materialien sind den Objekten falsch zu geordnet, also vertauscht, habs im Objektmanager einfach richtig verschoben und es geht, ansonsten keine Fehler vorhanden, kann sein das die Vertauschung durch den 3ds Export aus max stammt, so das es in C4D falsch zu geordnet ist, aber ansonsten kein Problem und schnell korriegiert.

Gruß Micha.

m3d|c4t

unregistriert

11

Sonntag, 18. Januar 2009, 19:02

*.3ds ist ein Exportcontainer, von 3ds Max. Beinhalten tut er bzgl. 3D Daten ausschließlich triangulierte Polygone.
*.max ist das native 3D Format von 3ds Max zur Projektspeicherung. Es kann alles beinhalten, was die 3ds Programmversion unterstützt. Somit auch vier- und mehrseitige Polygone, Kurvendaten, Partikel usw.

3ds Max kann *.3ds nativ öffnen. Gängige 3D Pakete, die Polygonbearbeitung beherrschen, können *.3ds nur importieren, manche zusätzlich auch exportieren. Import und Export verursachen stets Probleme. Bei 3ds-Import, sind es die angesprochenen Texturverlinkungen, die seltenst korrekt importiert werden.
Eine *.3ds Datei in Cinema4D importiert, hat genau dieselbe Qualität und Funktion, wie als würdest du sie in 3ds Max öffnen. In solch einer Datei gespeicherte Daten sind, wie erklärt, von Haus aus schon auf den kleinsten gemeinsamen Nenner herunterbrochen. Einzig und allein die Texturverlinkungen funktionieren in 3ds Max einwandfrei.

Aldaros

Timelord

  • »Aldaros« ist männlich

Beiträge: 681

Dabei seit: 24. August 2005

  • Private Nachricht senden

12

Sonntag, 18. Januar 2009, 19:13

@Micha AAaaaaahhhhh :D Aweil

Wer kommt denn aber auf sowas?? Eine Vertauschung der Texturen hatte ich bis jetzt auch noch nicht....da hätt ich lang an den einstellungen feilen können.
"Filme drehen ist entweder eine wunderbare Utopie oder Scheisse den Berg hochschaufeln"

Sir Sean Connery

"...und es steht geschrieben: Wenn du einschenkst,wird er kommen"

Denny Crane
[myshare]p14696681446[/myshare]

MichaMedia

unregistriert

13

Sonntag, 18. Januar 2009, 19:23

Nun war eigentlich schnell und leicht zu erkennen, da der Cube nun mal Texturlos aussah, cube aussen bekamm die schwarze Textur, cube mitte die mit dem eigentlichen Muster und cube innen habe ich auch das schwarz gegeben, also nur verschoben alles im Objekt Manager und vola, es sieht so aus, wie es soll.

Aber sowas hatte ich auch noch nie, wie gesagt nur mal bei einem Ferrarie waren Fehler.

Gruß Micha.

Iquitos

unregistriert

14

Montag, 19. Januar 2009, 17:09

Joa erstmal vielen Dank für die zahlreichen Antworten. Ich kann die Dateien in Cinema4D importieren, aber halt ohne Textur, die kann man ja noch im nachhinein drüber legen. Es gibt halt nur ein paar Dateien, die nicht kompatibel sind, irgendwelche falsch gerenderten 3ds Dateien.

Social Bookmarks