Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Amateurfilm-Forum. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

KingCerberus

unregistriert

1

Mittwoch, 19. Mai 2004, 17:36

Filme richtig komprimieren.

Ok, da das Komprimieren immer so ein Problem darstellt, schreibe ich folgendes Tutorial.

1. Was brauchen wir?

Am besten Komprimieren, kann man mit Virtual Dub , einem DivX 6.x Codec für das Video und einen MPEG 3 Codec für den Sound.

2. Ok was, wenn wir alles installiert haben?
Dann braucht ihr nur noch Euer Video und könnt los legen.
Am wichtigsten ist, dass ihr eure Videos immer unkomprimiert aus Adobe Premier/After Effects/etc. exportiert. Denn für das Komprimieren ist ganz zum Schluss Virtual Dub zuständig. Nachdem ihr dann Euer unkomprimiertes Video habt, (welches schonmal mehrere GigaByte gross sein kann) startet ihr Virtual Dub.


File -> Open video file und sucht Euer Video aus.


Dann stellt ihr eure Codecs richtig ein. Fangen wir mit den Video Einstellungen an. Video -> Compression, Euren DivX.5.x Codec auswählen, -> Configure und die Encoding Bitrate auf ca. 400- 500 kbps stellen.



Hier könnt ihr selber entscheiden, wie gut die Qualität sein soll. Probiert einfach ein wenig aus, bis ihr mit der Qualität/Größe zufrieden seid. Dann nur noch mit Ok bestätigen. Weiter machen wir mit dem Sound. Audio -> Full processing mode ,


Anschliessend auf compression . Hier noch MPEG Layer-3 anklicken und Euer Format auswählen. Auch hier gilt wieder, probieren geht über studieren.


Wenn ihr alle Einstellungen erledigt habt, geht auf File -> Save as AVI, gebt einen Namen ein und auf OK klicken.

Wenn Euer Film fertig ist, sollte er eigentlich eine akzeptable Größe erreicht haben.

WICHTIG!!!: Es kommt auch darauf an, welche größe Euer Video hat. Ein Video mit 756x480 Auflösung ist natürlich größer als ein Video mit 320x240 Pixel. Für Internetvideos, sollte letzteres eigentlich genügen.

Fall ein Link zu einem Programm/Codec nicht mehr richtig funktionieren sollte, schreibt es bitte hier rein, ich werde dann umgehend einen neuen Link angeben.

Ich hoffe, ich konnte ein wenig helfen.

Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von »Purzel« (12. Februar 2007, 04:41)


Dead-Eye

unregistriert

2

Donnerstag, 2. September 2004, 23:40

Hmm, so wie ich das sehe, ändert die Auflösung fast gar nichts. Hab mittels "Video -> Filter -> resize" die Auflösung runtergesetzt, aber die Größe ändert sich nur um ein paar Kilobytes. Muss man vielleicht die Auflösung woanders heruntersetzen ? Bei den codecs hab ich jedenfalls keine solche Option gefunden.

Außerdem hab ich so einen Balken wo man die Qualität zugunsten der Komprimierung herabsetzen kann, nicht gefunden (bei DivX pro 5.2.0) nur vorgefertige Schemas. Bei "langsam" verspricht er beste Komprimierung und Qualität, aber geht's wirklich nicht auch kleiner ?

KingCerberus

unregistriert

3

Freitag, 3. September 2004, 00:24

Nun, ich weiß nicht genau wie sich das Größenverhältnis ändert, wenn du die Auflösung in VD änderst, ich meinte nämlich das Format, welches du aus dem Schnittprogramm exportierst.
Verändere mal die Auflösung in Premier,Magix, (oder welches Prog. du benutzt) zu ändern.

Dead-Eye

unregistriert

4

Freitag, 3. September 2004, 02:15

Ok, ich hab es jetzt mit dem Programm "Vegas 4.0" versucht, da gibt kann man bei "Templates" einiges einstellen u.a die Auflösung. Ich nehme an du meinst das.
Es klappt auch ganz gut, das Video ist wirklich nur noch halb zu groß (im wahrsten Sinne des Wortes ;))
aber jetzt hab ich ein anderes Problem, und zwar ist in dem Video alle 5 Sekunden kurz ne schwarze Fläche mit nem roten "X" drauf. Ich hab dann einwenig mit den Einstellungen rumgespielt aber weiß immer noch nicht, woran es liegt.

Purzel

Medienmogul

  • »Purzel« ist männlich

Beiträge: 3 313

Dabei seit: 7. August 2003

Hilfreich-Bewertungen: 184

  • Private Nachricht senden

5

Freitag, 3. September 2004, 02:20

Die Größe der Datei und die Bild-Auflösung sollten sich definitiv ändern.
Mal Dir mal ein Bild mit einem Rechteck (als Bildschirm).
Jetzt zeichne ein Kreuz mitten hinein.
Wenn Du von der vollen Auflösung das Video halbierst, verkleinert sich die Dateigröße um das Vierfache... schau das Bild an und Du wirst verstehen....
Die meisten Codecs haben noch komprimierungs-Optionen... (Datenrate oder ähnliche)

Das mit dem roten X kann an zwei Dingen liegen:
Entweder ist eine Art "Schutz", weil Du eine nicht freigeschaltete Demo-Version hast, oder Du hast z.B. irgendwelche Blenden nicht gerendert...
Wenn Amateurfilmen einfach wäre, hieße es RTL.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Purzel« (3. September 2004, 02:22)


Der Unaussprechliche

Registrierter Benutzer

  • »Der Unaussprechliche« ist männlich

Beiträge: 738

Dabei seit: 15. Juni 2005

Wohnort: Neubiberg

  • Private Nachricht senden

6

Samstag, 6. August 2005, 18:53

das tutorial is zwar schon recht alt aber ich hab trotzdem noch ein problem.
und zwar wenn ich ein video kompriemiere dann bekommt es bei mir immer diese interlacing streifen obwohl die davor noch nicht da waren. ich hab mir den neusten codec von divx.com runtergeladen. aber kann man das video nicht ohne die interlacingstreifen kompriemieren? in den meisten videos hier im forum sieht man doch auch keine interlacingstreifen.

Ostinox

unregistriert

7

Samstag, 6. August 2005, 19:07

Weiß zwar net ob des dir weiterhilft aber geh mal Video -> Filters -> Deinterlace und stell dort "Blend fields together" ein.
Vielleicht hilft des.

Geilfried

Registrierter Benutzer

  • »Geilfried« ist männlich

Beiträge: 93

Dabei seit: 10. Juli 2005

Wohnort: Olfen

  • Private Nachricht senden

8

Mittwoch, 16. November 2005, 15:12

Hallo, ich habe ein Problem beim Sound. In dem Fenster für den MP3 Codec wird bei mir nichts angezeigt. Ich habe aber den Codec installiert.
Weiß jemand woran das liegen kann?

Marcus Gräfe

Administrator

  • »Marcus Gräfe« ist männlich

Beiträge: 5 021

Dabei seit: 14. August 2002

Wohnort: Düsseldorf

Hilfreich-Bewertungen: 312

  • Private Nachricht senden

9

Mittwoch, 16. November 2005, 15:57

Taucht der Codec in der linken Liste nicht auf oder hast du nur keine Formate in der rechten Liste? In beiden Fällen empfielt sich die Neuregistrierung/Neuinstallation des MP3 Codecs.

TombDavid1

Registrierter Benutzer

  • »TombDavid1« ist männlich

Beiträge: 549

Dabei seit: 19. November 2004

Wohnort: Mönchengladbach

  • Private Nachricht senden

10

Mittwoch, 16. November 2005, 16:00

Ich hab ein ähnliches Problem ich komm in dieses Compression Fenster rein obwohl ich zwei oder drei MP3 Codecs drauf hab
Gedanken spielen eine wichtige rolle im Leben eines menschen. Wer denkt, er ist ein Versager, wird auch einer bleiben. Wer denkt, er ist krank, wird auch krank sein.

Burger King

unregistriert

11

Mittwoch, 16. November 2005, 16:09

@ TombDavid wo ist das den jetzt ein Problem er findet den codec garnicht in der Liste, aber du hast 3 davon und wenn es funktioniert ist es doch kein Problem ^^

Geilfried

Registrierter Benutzer

  • »Geilfried« ist männlich

Beiträge: 93

Dabei seit: 10. Juli 2005

Wohnort: Olfen

  • Private Nachricht senden

12

Mittwoch, 16. November 2005, 16:39

So ich hab hier nochma einen Screenshot von dem Problem:



Wie kann man den Codec eigentlich deinstallieren?

Genesis

unregistriert

13

Sonntag, 15. Januar 2006, 17:38

hab das gleiche problem wie geilfried.
hab den codec installiert, er wurde nicht angezeigt (wie in seinem screenshot), hab ihn auch mehrmals neuinstalliert oder bei nem anderen mirror gezogen, ging aber nicht.

Ich wäre euch dankbar, wenn ihr den Thread nochmal aufnehmen könntet.

Geilfried

Registrierter Benutzer

  • »Geilfried« ist männlich

Beiträge: 93

Dabei seit: 10. Juli 2005

Wohnort: Olfen

  • Private Nachricht senden

14

Sonntag, 15. Januar 2006, 18:11

Also ich habe das Problem jetzt so gelöst, dass ich mir den LAME Mp3 Codec gesaugt und installiert habe. Ich komprimiere dann immer damit. Klappt eigentlich ohne Probleme. Such einfach mal bei Google danach. Findet man sehr schnell :)

15

Sonntag, 22. Januar 2006, 18:22

hab dasselbe problem wie Geilfried, weiss denn keiner eine lösung :(

Geilfried

Registrierter Benutzer

  • »Geilfried« ist männlich

Beiträge: 93

Dabei seit: 10. Juli 2005

Wohnort: Olfen

  • Private Nachricht senden

16

Sonntag, 22. Januar 2006, 19:09

Wie gesagt, hol dir den LAME MP3 Codec. Klappt damit genauso gut, ist halt nur von einer anderen Firma.

Genesis

unregistriert

17

Sonntag, 22. Januar 2006, 20:37

hab mir den lame mp3 codec auch gesaugt, aber der wird bei mir nicht in der codec liste angezeigt. und im lame mp3 encoder kann man keine videos mitbverarbeiten und manb kann auch nicht den sound als mp3 in virtual dub zum video hinzuziehen.

also ich habs bis jetzt immer noch nicht hinbekommen.

18

Montag, 23. Januar 2006, 19:46

jo, bei mir auch dasselbe problem, der wird gar nicht erst in der liste angezeigt

KingCerberus

unregistriert

19

Montag, 23. Januar 2006, 20:58

Mhh scheinbar funzt der Codec bei vielen Leuten nicht mehr richtig.
Hab hier mal ne Rar Datei erstellt.
Exportiert die bitte mal und schaut ob das so funzt.

MPEG 3 Codec

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »KingCerberus« (23. Januar 2006, 21:06)


Genesis

unregistriert

20

Montag, 23. Januar 2006, 22:24

"codec does'nt support configuration. it's probably an older version"

Social Bookmarks